Wednesday, December 19, 2007

Cisco QoS Samples

Cisco QoS

Cisco QoS Sample 1

www-server with at least 80KBit bandwidth.

!
class-map match-any lan
match access-group name lan
!
policy-map www
class lan
priority 80
set precedence 7
!
ip access-list extended lan
permit tcp any eq www any
!
interface Ethernet1
description DSL_PPPOE_Interface
mac-address 5254.05f0.edc3
bandwidth 768
no ip address
service-policy output dsl
ip tcp adjust-mss 1452
load-interval 30
half-duplex
pppoe enable
pppoe-client dial-pool-number 3
no cdp enable



Cisco QoS Sample 2

ftp-server and www-server should have at least 100kbit bw, but should not consume all available bw on datatransfer.

!
class-map match-any lan
match access-group name lan
class-map match-any weblinux_ftp
match access-group name weblinux
!
policy-map dsl
class weblinux_ftp
shape average 100000
set precedence 7
class lan
priority 80
compress header ip
set precedence 7
shape average 80000
class class-default
!
ip access-list extended weblinux
permit tcp any eq ftp-data any
permit tcp any eq www any
!
ip access-list extended lan
permit udp any gt 1023 any
permit tcp gt 1023 gt any
!
interface Ethernet1
description DSL_PPPOE_Interface
mac-address 5254.05f0.edc3
bandwidth 768
no ip address
service-policy output dsl
ip tcp adjust-mss 1452
load-interval 30
half-duplex
pppoe enable
pppoe-client dial-pool-number 3
no cdp enable