Tuesday, November 13, 2007

CONFIGURING NAT VIA ROUTE-MAPS

config-t.net » Blog Archive » CONFIGURING NAT VIA ROUTE-MAPS

BASIC NAT CONFIGURATION USING ROUTE MAPS

Configuring NAT(PAT) is basically a four step process.
1.) create an access-list to define what traffic is to be natted.
2.) create a route-map the matches the access-list defined in step 1.
3.) create the nat route-map statement the defines what route-map to use, what address to use for the nat translation.
4.) under each interface, define whether the interface is an inside or outside nat interface.

That is it- see below.

access-list 101 permit ip 192.168.0.0 0.0.0.255 any

route-map ROUTEMAP-NAT permit 1
match ip address 101
ip nat inside source route-map ROUTEMAP-NAT interface FastEthernet0/0 overload

interface FastEthernet0/0
description CONNECTION TO OUTSIDE
ip address 192.168.199.232 255.255.255.0
ip nat outside
!
interface FastEthernet0/1
description Internal LAN
ip address 192.168.0.254 255.255.255.0
ip nat inside